coco,

Je suis dessus depuis 4 jours et j'y arrive pas, j'ai épluché tout internet mais...

J'ai 2 "WAN", un ethernet (eth4) et un VPN (tun0). J'aimerais forward un port du VPN vers une machine qui se trouve sur un réseau local br0.

J'ai donc fait un DNAT, lequel semble fonctionner puisque les paquets ont l'air de bien transiter jusqu'à la machine (observé avec tcpdump). Leur provenance est le gateway de br0 et pas l'IP externe qui envoie sa requête à travers tun0.

De l'extérieur, en tentant sur l'IP publique de tun0, je timeout.

Je pense que les paquets sont bien routés vers ma machine de destination, mais qu'une fois que les paquets en réponse atteignent le gateway du réseau local br0, le routeur ne sait pas trop où les renvoyer. Je pense qu'il ne les route pas vers tun0 mais plutôt vers eth4. Ou qu'il n'en fait rien, je sais pas.

Ça doit être tout con, mais comment j'instruis au routeur de renvoyer les paquets à l'IP qui fait la requête et à travers tun0 ?

koneko,
@koneko@toot.beep.computer avatar

deleted_by_author

  • Loading...
  • coco,

    @koneko Réponds à la question, nerd. Les routes c'est toujours sérieux. ​:spin:​

  • All
  • Subscribed
  • Moderated
  • Favorites
  • linux
  • kavyap
  • ngwrru68w68
  • tacticalgear
  • DreamBathrooms
  • mdbf
  • magazineikmin
  • thenastyranch
  • Youngstown
  • Durango
  • slotface
  • everett
  • vwfavf
  • rosin
  • khanakhh
  • normalnudes
  • Leos
  • cisconetworking
  • cubers
  • InstantRegret
  • ethstaker
  • osvaldo12
  • modclub
  • anitta
  • provamag3
  • GTA5RPClips
  • tester
  • megavids
  • JUstTest
  • All magazines