nithinbekal,
@nithinbekal@ruby.social avatar

PSA: If you're using Ruby LSP on neovim with nvim-lspconfig, I just renamed the config name from ruby_ls to ruby_lsp, and you might see a warning like this:

ruby_ls is deprecated, use ruby_lsp instead.
This feature will be removed in lspconfig version 0.2.0

The LSP will continue to work, but if your LSP setup doesn't use something like mason, you should be able to replace ruby_ls with ruby_lsp to avoid this warning.

Context: https://github.com/neovim/nvim-lspconfig/pull/3105

  • All
  • Subscribed
  • Moderated
  • Favorites
  • neovim
  • DreamBathrooms
  • mdbf
  • ethstaker
  • magazineikmin
  • GTA5RPClips
  • rosin
  • thenastyranch
  • Youngstown
  • osvaldo12
  • slotface
  • khanakhh
  • kavyap
  • InstantRegret
  • Durango
  • provamag3
  • everett
  • cisconetworking
  • Leos
  • normalnudes
  • cubers
  • modclub
  • ngwrru68w68
  • tacticalgear
  • megavids
  • anitta
  • tester
  • JUstTest
  • lostlight
  • All magazines