eager_eagle,
@eager_eagle@lemmy.world avatar

The liberty to not name things that are obvious.

and that’s yet another way to end up with hard to read code.

Variables hold values that have meaning. Learn how to name things and you’ll write good code.

jeffhykin,

Is it just me or does it feel kinda unclean for it to just support 1 through 9?

eager_eagle,
@eager_eagle@lemmy.world avatar

tbf positional arguments are already bad enough. Now if you’re using over 9 positional args… just take a break, go for a short walk, and maybe you’ll come back with a better plan

bnjmn,

OMG looks like Raku

Knusper,

I do think the unnumbered variant of such anonymous parameters is useful, if you’ve got a team of devs that knows not to misuse them.

In particular, folks who are unexperienced will gladly make massive multi-line transformations, all in one step, and then continue blathering on about it or similar, as if everyone knew what they were talking about and there was no potential for ambiguity.

This is also particularly annoying, because you rarely read code top-to-bottom. Ideally, you should be able to jump into the middle of any code and start reading, without having to figure out what the regional abbreviations or it mean.

AnUnusualRelic,
@AnUnusualRelic@lemmy.world avatar

Is ruby the new Perl?

marcos,

That deserves an “always has been” meme… But IMO, Ruby outperled Perl since the beginning.

Perl doesn’t let you redefine the syntax so that you can write the same program multiple ways. All it does is to encourage multiple programs to have the same meaning.

AnUnusualRelic,
@AnUnusualRelic@lemmy.world avatar

I never looked at Ruby, but that doesn’t seem like it would be great for readability (although maybe productivity).

marcos,

People mostly refrain from using it.

Much like people used to create an idiom in Perl and stick to it.

morrowind,
@morrowind@lemmy.ml avatar

It’s designed to be as readable as english.

Take that as you will

twelvefloatinghands,
@twelvefloatinghands@lemmy.world avatar

Damn, I wish rust had that

colonial,
@colonial@lemmy.world avatar

It wouldn’t be as relevant, since passing a function or method instead of a closure is much easier in Rust - you can just name it, while Ruby requires you to use the method method.

So instead of .map(|res| res.unwrap()) you can do .map(Result::unwrap) and it’ll Just Work™.

vidarh,
@vidarh@lemmy.stad.social avatar

In the case of your example we’d do .map(&:unwrap) in Ruby (if unwrap was a method we’d actually want to call)

Notably, these are not the cases _1 and _2 etc are for. They are there for the cases that are not structurally “call this method on the single argument to the block” e.g. .map{ _1 + _2 } or .map { x.foo(_1) }

(_1 is reasonable, because iterating over an enumerable sequence makes it obvious what it is; _1 and _2 combined is often reasonable, because e.g. if we iterate over a key, value enumerable, such as what you get from enumerating a Hash, it’s obvious what you get; if you find yourself using _3 or above, you’re turning to the dark side and should rethink your entire life)

jendrik,

Except when Type::Method takes a reference, then it doesn’t just work

morrowind,
@morrowind@lemmy.ml avatar

Ruby lets you do .map(&:unwrap) no need for results

edit: lemmy keeps adding in the &, not sure how to avoid that

Anders429,

I sincerely doubt Rust would ever add something like this.

paperplane,

Swift does, though using the dollar sign rather than underscores

TheCee,

I’m glad it doesnt.

  • All
  • Subscribed
  • Moderated
  • Favorites
  • programming@programming.dev
  • kavyap
  • thenastyranch
  • cubers
  • ethstaker
  • InstantRegret
  • DreamBathrooms
  • ngwrru68w68
  • magazineikmin
  • everett
  • Youngstown
  • mdbf
  • slotface
  • rosin
  • GTA5RPClips
  • JUstTest
  • khanakhh
  • normalnudes
  • osvaldo12
  • cisconetworking
  • provamag3
  • Durango
  • tacticalgear
  • modclub
  • Leos
  • megavids
  • tester
  • anitta
  • lostlight
  • All magazines